Tem 14 2009

IsPostBack was always false after installing .NET Framework 3.5 SP1

Category: .Net frameworksLatif @ 02:19

Hi,

 After installing .NET 3.5 SP1, I realized some problems on my old project which has written on framework 2.0.

 My observations/symptoms on the project-login form:

  • IsPostBack was always false
  • İmagebutton click event not firing
  • I could not login the system

     After 2 days searching  ,luckily I stumbled upon following page. Thanks god :) http://blogs.msdn.com/tess/archive/2009/04/14/validation-of-viewstate-mac-failed-after-installing-net-3-5-sp1.aspx?CommentPosted=true#commentmessage

 

 Cause:

 There was a form tag in the Login.aspx. Pay attention to action="Default.aspx" (this was the problem)

<form id="form1" method="post" action="Default.aspx" runat="server">

 This problem may occur if your page(in this case Login.aspx) and  form action property(Default.aspx) are different.

 Reason :

      This occurs after installing SP1 for .NET 3.5 is because prior to this service pack, the action property was ignored.  Now that it is no longer ignored.It will work properly. I mean, this is not a bug, it’s a feature...

 Solution:

       Remove the form-action property or change it to post correct page(in this case Login.aspx).

 References :

 http://blogs.iis.net/webtopics/archive/2009/05/13/httpexception-due-to-invalid-viewstate-after-installing-net-framework-3-5-sp1.aspx

 

http://blogs.msdn.com/tess/archive/2009/04/14/validation-of-viewstate-mac-failed-after-installing-net-3-5-sp1.aspx?CommentPosted=true#commentmessage

See you soon....

 

Tags: